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7 WORkING WItH  
SOUND AND VIDEO

Lesson Overview
In this lesson, you’ll learn how to do the following:

• Import sound files

• Edit sound files

• Use the Adobe Media Encoder

• Understand video and audio encoding options

• Play external video from your Flash project

• Customize options on the playback component

• Work with video that contains alpha channels

• Embed video in your Flash project

This lesson will take approximately two hours to complete. If needed, 
remove the previous lesson folder from your hard drive and copy the 
Lesson07 folder onto it. 
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Sound and video add new dimensions to your projects. 
Import sound fi les and edit them directly in Flash, and 
use the Adobe Media Encoder to compress and convert 
video fi les to use in Flash.

Chapter 7. Working with Sound and Video. Adobe® Flash® CS4 Professional Classroom in a Book®, ISBN: 9780321606600
Prepared for matthew@choppingblock.com, Matthew Richmond
© 2009 Adobe System Incorporated and its Licensors.. This PDF is made available for personal use only during the relevant subscription term, subject to the Safari Terms of Service. Any
other use requires prior written consent from the copyright owner. Unauthorized use, reproduction and/or distribution are strictly prohibited and violate applicable laws. All rights reserved.

Licensed by
Matthew Richmond

250880



240 lesson 7 Working with sound and Video

Getting Started
Start the lesson by viewing the finished animated zoo kiosk. You’ll create the kiosk 
by adding sound and video files to a project in Flash. 

1 Double-click the 07End.swf file in the Lesson07/07End folder to play the 
animation.

View the movie of the polar bear with a short soundtrack of an African beat. A 
zoo director appears on the screen, speaks, and then disappears. 

2 Click a sound button to hear an animal sound. 

3 Click a thumbnail button to view a short movie about the animal.

In this lesson, you’ll import audio files and put them on the Timeline to provide the 
short audio flourish. You’ll also learn how to embed sounds in each button. You’ll 
use the Adobe Media Encoder to compress and convert the video files to the appro-
priate format for Flash. You’ll also learn how to work with transparent backgrounds 
in video to create the silhouetted zoo director video. 

1 Double-click the 07Start.fla file in the Lesson07/07Start folder to open the initial 
project file in Flash.

2 Choose File > Save As. Name the file 07_workingcopy.fla, and save it in the 
07Start folder. Saving a working copy ensures that the original start file will be 
available if you want to start over. 
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Understanding the Project File
The initial setup of the project has been completed except for the audio and video 
portions. The Stage is 1000 x 700 pixels. A row of buttons of colorful animals is on 
the bottom row, another set of buttons on the right, a title at the top, and a back-
ground image of a resting lion.

The Timeline contains several layers that separate the different content. 

The bottom three layers, called background photo, title, and bottom navbar, contain 
design elements, text, and images. The next two layers above, called buttons and 
sound buttons, contain instances of button symbols. The content layer contains 
several labeled keyframes, and the actions layer contains ActionScript that provides 
the event handlers for the bottom row of buttons.
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If you’ve completed the previous chapter, you should be familiar with the structure 
of this Timeline. The individual buttons on the bottom row are coded so that when 
the user clicks a button, the playhead moves to a corresponding labeled keyframe. 
You’ll be inserting content into each of those keyframes. But first you’ll learn to 
work with sound.

Using Sounds
You can import several types of sound files into Flash. Flash supports MP3, WAV, 
and AIFF files, which are three common kinds of sound formats. When you import 
sound files into Flash, they are stored in your Library. You can then drag the sound 
files from the Library on to the Stage at different points along the Timeline to syn-
chronize those sounds to whatever may be happening on the Stage.

Importing Sound Files
You’ll import several sound files in the Library to be used throughout this lesson.

1 Choose File > Import > Import To Library. 

2 Select the Monkey.wav file in the Lesson07/07Start/Sounds folder, and click 
Open (Windows) or Import To Library (Mac OS).

The Monkey.wav file appears in your Library. The sound file is indicated by a 
unique icon, and the preview window shows a waveform—a series of peaks and 
valleys that represent the sound.
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3 Click the Play button on the far upper-right corner of the Library preview 
window. 

The sound plays.

4 Double-click the sound icon in front of your Monkey.wav file.

The Sound Properties dialog box appears, providing information on your sound 
file, including its original location, size, and other technical properties.

5 Choose File > Import > Import To Library and select the other sound files to 
import into your Flash project. Import Elephant.wav, Lion.wav, Africanbeat.
mp3, and Afrolatinbeat.mp3.

Your Library should contain all the sound files.

6 Create a folder in your Library and place all the sound files inside it to organize 
your Library. Name the folder sounds.
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Where to Find Sound Clips
If you’re looking for interesting sounds 
to use in your Flash movie, you can use 
the free sound files available from Adobe. 
Flash CS4 comes preloaded with dozens 
of useful sounds that you can access by 
choosing Window > Common Libraries > 
Sounds. An external library (a library that 
is not connected to the current project) 
appears.

Simply drag one of the sound files from 
the external library on to your Stage. The 
sound will appear in your own Library.

Placing Sounds on the timeline
You can place a sound at any point along the Timeline, and Flash will play that 
sound when the playhead reaches the keyframe. You’ll place a sound on the very 
first keyframe to play as the movie starts to provide a pleasant audio introduction 
and set the mood.

1 Select the content layer on the Timeline. 

2 Insert a new layer and rename it sounds. 

3 Select the first keyframe of the sounds layer.

4 Drag the Afrolatinbeat.mp3 file from the sounds folder in your Library on to the 
Stage.
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The waveform of your sound appears on the Timeline.

5 Select the first keyframe of the sounds layer. 

In the Property inspector, note that your sound file is now listed on the pull-
down menu under the Sound section.

6 Select Stream for the Sync option. 
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The Sync options determine how the sound plays on the Timeline. Use Stream 
sync for long passages of music or narration when you want to time the sound 
with the Timeline.

7 Move the playhead back and forth on the Timeline. 

The sound plays as you scrub the Timeline.

8 Choose Control > Test Movie. 

The sound plays only for a short while before getting cut off. Because the sound 
is set to Stream, it only plays when the playhead moves along the Timeline. 
There is a stop action at frame 9 that stops the playhead, and hence, stops  
the sound. 

Adding Frames to the timeline
The next step is to extend the Timeline so that the entire sound (or at least the por-
tions that you desire) plays before the stop action.

1 Click on the Stage to deselect the Timeline, and then place the playhead 
between frames 1 and 9 by clicking on the top frame numbers. 

2 Choose Insert > Timeline > Frame, or press F5, to insert frames in all the layers 
between frames 1 and 9. 

3 Insert enough frames so that the entire Timeline extends to frame 80.

4 Choose Control > Test Movie. 

The sound lasts longer because it has more frames to play before the  
playhead stops.
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Clipping the End of a Sound
The sound clip you imported is a bit longer than you need. You’ll shorten the sound 
file by using the Edit Envelope dialog box. Then you’ll apply a fade so that the sound 
gradually decreases as it ends.

1 Select the first keyframe of the sounds layer. 

2 In the Property inspector, click the Edit button. 

The Edit Envelope dialog box appears, showing you the waveform. The top and 
the bottom waveform are the left and right channels of the sound (stereo). A 
timeline is between the waveforms, a pull-down menu of preset effects at the 
left corner, and view options at the bottom.

Preset effects

Left channel

Right channel

Play controls

Timeline

View options

Chapter 7. Working with Sound and Video. Adobe® Flash® CS4 Professional Classroom in a Book®, ISBN: 9780321606600
Prepared for matthew@choppingblock.com, Matthew Richmond
© 2009 Adobe System Incorporated and its Licensors.. This PDF is made available for personal use only during the relevant subscription term, subject to the Safari Terms of Service. Any
other use requires prior written consent from the copyright owner. Unauthorized use, reproduction and/or distribution are strictly prohibited and violate applicable laws. All rights reserved.
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3 In the Edit Envelope dialog box, click the Seconds icon. 

The timeline changes units to show seconds instead of frames. You can click the 
Frames icon to switch back, depending on how you want to view your sound.

4 Click the Zoom Out icon until you can see the entire waveform.

The waveform appears to end at around 120 frames, or about 10 seconds.

5 Drag the right end of the time slider inward to about frame 40. 

The sound shortens by being clipped from the end. The sound now only plays 
for about 40 frames. 
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6 Click OK to accept the changes you’ve made. 

The waveform on the main Timeline indicates the shortened sound. 

Changing the Volume of a Sound
The sound will be more elegant if it slowly fades out instead of being abruptly cut off. 
You can change the volume levels through time in the Edit Envelope dialog box. 

1 Select the first keyframe of the sounds layer. 

2 In the Property inspector, click the Edit button. 

The Edit Envelope dialog box appears.

3 Select the Frames viewing option, and zoom in on the waveform to see its end 
near frame 40. 
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4 Click on the top horizontal line of the top waveform above frame 35. 

A box appears on the line, indicating a keyframe for the sound volume.

5 Click on the top horizontal line of the upper waveform above frame 40 and drag 
it down to the bottom of the window. 

The downward diagonal line indicates the drop in volume from 100% to 0%. 
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6 Click on the corresponding keyframe on the lower waveform and drag it down 
to the bottom of the window. 

The volume levels for both the left and right channels slowly decrease starting at 
frame 35. By frame 40, the volume level is at 0%. 

7 Test the effects of your sound edits by clicking the Play button on 
the lower-left side of the dialog box. Click OK to accept the changes.

Deleting or Changing the Sound File
If you don’t want the sound on your Timeline, or you want to change the sound to 
a different one, you can make those changes from the Property inspector. 

1 Select the first keyframe of the sounds layer. 

2 In the Property inspector, select None in the Name pull-down menu. 

The sound is removed from the Timeline.

Note:##  You can apply 
some of the preset 
effects from the pull-
down menu in the Edit 
Envelope dialog box 
by just choosing them. 
Common effects like 
a fade in or a fade out 
are provided for your 
convenience.
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3 Select Africanbeat.mp3 for Name. 

The Africanbeat.mp3 sound is added to the Timeline.

Increasing the quality of the Sounds
The default settings on a new Flash project use fairly high compression on sounds, 
which results in poor-quality audio. It’s best to increase the quality of the sound 
export through the Publish Settings options.

1  Choose File > Publish Settings. 

The Publish Settings dialog box appears.

2 Click the Flash tab and click the Set button for the Audio Stream options. 
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The Sound Settings dialog box appears.

3 Increase the Bit rate to 48 kbps.

The Bit rate determines the quality of the sound in your final, exported Flash 
movie. The higher the bit rate, the better the quality. However, the higher the 
bit rate, the larger your file becomes. You must determine the balance of quality 
and file size based on the minimum acceptable level of quality.

4 Deselect the option to Convert stereo to mono. 

Stereo sounds will be preserved. The Africanbeat.mp3 file in particular relies on 
stereo effects, so keeping both the left and right channels is important. Click OK 
to accept the settings.

5 Click the Set button for the Audio Event options. 

The Sound Settings dialog box appears.

6 Increase the Bit rate to 48 kbps and deselect the option to Convert stereo to 
mono. Click OK to accept the settings.

Both the Audio Stream and Audio Event settings should be at 48 kbps with Stereo.

7 Select Override sound settings.

Chapter 7. Working with Sound and Video. Adobe® Flash® CS4 Professional Classroom in a Book®, ISBN: 9780321606600
Prepared for matthew@choppingblock.com, Matthew Richmond
© 2009 Adobe System Incorporated and its Licensors.. This PDF is made available for personal use only during the relevant subscription term, subject to the Safari Terms of Service. Any
other use requires prior written consent from the copyright owner. Unauthorized use, reproduction and/or distribution are strictly prohibited and violate applicable laws. All rights reserved.



254 lesson 7 Working with sound and Video

The sound settings in the Publish Settings will determine how all your sounds 
are exported.

8 Choose Control > Test Movie. 

The quality of the sound will be greatly increased in your exported SWF.

Adding Sounds to Buttons
In the kiosk, the buttons appear in a column on the right. You’ll add sounds to the 
buttons so that they play whenever the user clicks them.

1 In the Library, double-click the icon of the button symbol called sound_button1. 

You enter symbol-editing mode for that button symbol.

2 There are three layers in the button symbol to help organize the content for the 
Up, Over, Down, and Hit keyframes.

3 Insert a new layer and rename it sounds. 

4 Select the Down frame in your sounds layer and insert a keyframe. 

A new keyframe appears in the Down state of your button.
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5 Drag the Monkey.wav file from the sounds folder in your Library to the Stage.

A waveform for the Monkey.wav file appears in the Down keyframe of the 
sounds layer.

6 Select the Down keyframe in the sounds layer.

7 In the Property inspector, choose Start for the Sync option. 

A Start sync option triggers the sound whenever the playhead enters that 
particular keyframe.

8 Choose Control > Test Movie. Test the first button to hear the monkey, and 
then close the preview window. 

9 Edit the sound_button2 and the sound_button3 to add the Lion.wav and the 
Elephant.wav sounds to their Down frames. 

Understanding Sound Sync Options
Sound sync refers to the way the sound is triggered and played. There are several 
options: Event, Start, Stop, and Stream. Stream links the sound to the Timeline so 
you can easily synchronize animated elements to the sound. Event and Start are 
used to trigger a sound (usually a short sound) to a specific event, like a button click. 
Event and Start are similar except that the Start sync does not trigger the sound if it 
is already playing (so there are no overlapping sounds possible with Start sync). The 
Stop option is used to stop a sound, although you’ll use it rarely, if ever. If you want 
to stop a sound with a Stream sync, simply insert a blank keyframe.
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Understanding Flash Video
Flash is fast becoming the de facto method of delivering video over the Web. In 
fact, more Internet users can view video with Flash than with any other technology 
including QuickTime, Windows Media Player, or RealPlayer. News sites such as the 
New York Times and content sharing sites such as YouTube all use Flash to present 
video.

Adding video to Flash is easy, whether you want to present straight video alone, or 
whether you want to incorporate it with other animated elements. There are two 
options to display video in Flash. The first option is to embed the video in your 
Flash file, and the second option is to keep the video separate from your Flash file 
and use a playback component from Flash to play the video.

Both methods require that the video be formatted correctly first. The appropriate 
video format for Flash is Flash Video, which uses the extension .flv or the extension 
.f4v. F4V is the latest Flash Video format that supports the H.264 standard, a state-
of-the-art video codec that delivers high quality with remarkably efficient compres-
sion. A codec (compression-decompression) is a method computers use to com-
press a video file to save space, and then decompress it to play it back. FLV is the 
standard format for previous versions of Flash and uses the older codecs Sorenson 
Spark or On2VP6.

Using the Adobe media Encoder
You can convert your video files to the FLV or F4V format using the Adobe Media 
Encoder CS4, a stand-alone application that comes with Flash CS4. The Adobe 
Media Encoder can convert single files or multiple files (known as batch process-
ing) to make your workflow easier.

Adding a Video File to the Adobe media Encoder
The first step to convert your video file to a compatible Flash format is to add the 
video to the Adobe Media Encoder for encoding.

1 Launch the Adobe Media Encoder, which comes installed with Adobe Flash CS4.

The opening screen displays a window that lists any current video files that have 
been added for processing. The window should be empty.

Note:##  Flash can 
actually play back 
any video encoded in 
H.264, so your video 
file doesn’t have to 
have the .f4v extension. 
For example, a video 
with a .mov extension 
encoded by QuickTime 
Pro with H.264 is 
compatible with Flash.
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2 Choose File > Add or click the Add button on the right. 

A dialog box opens for you to select a video file. 

3 Navigate to the Lesson07/07Start folder, select the Penguins.mov file, and  
click OK.

The Penguins.mov file is added to the display list and is ready for conversion to 
an FLV or F4V format.

Note:##  You can also 
drag the file directly to 
the queue from your 
Desktop.

Chapter 7. Working with Sound and Video. Adobe® Flash® CS4 Professional Classroom in a Book®, ISBN: 9780321606600
Prepared for matthew@choppingblock.com, Matthew Richmond
© 2009 Adobe System Incorporated and its Licensors.. This PDF is made available for personal use only during the relevant subscription term, subject to the Safari Terms of Service. Any
other use requires prior written consent from the copyright owner. Unauthorized use, reproduction and/or distribution are strictly prohibited and violate applicable laws. All rights reserved.



258 lesson 7 Working with sound and Video

Converting Video Files to Flash Video
1 In the options under Format, select the FLV/F4V (H.264) option. 

2 Under the Preset options, choose F4V-Web Medium. 

You can choose one of many of the standard preset options from the menu. 
The options determine the format (either the newer F4V or the older FLV) and 
the size of the video. The Web Medium option converts your original video to 
360 pixels wide by 272 pixels high, which is an average size to display video in a 
Web browser. In parentheses, Flash indicates the minimum Flash Player version 
required to play the selected video format.

3 Click on the Output File.

You can choose to save the converted file in a different location on your 
computer and choose a different filename. Your original video will not be 
deleted or altered in any way.

4 Click Start Queue.

Flash begins the encoding process. Flash displays the settings for the encoded 
video and shows the progress and a preview of the video.
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When the encoding process finishes, a green check in the display list indicates 
that the file has been converted successfully. You now have the file, Penguins.f4v 
in your Lesson07/07Start folder, along with the original Penguins.mov file.

Note:##  If you have multiple video files to encode to F4V or FLV format, you can do so all at 
once and easily with the Adobe Media Encoder in a process known as batch processing. Each 
file can even have its own settings. Click the Add button to add videos to the display list. Choose 
a different format for each file, if desired. Click Start Queue to begin the batch processing. In the 
following figure, two additional files are in line to be encoded.

Note:##  You can change the status of individual files in the queue by selecting the file in the 
display list and choosing Edit > Reset Selection or Edit > Skip Selection. Reset Selection removes 
the green check from a completed file so it can be encoded again, whereas Skip Selection 
makes Flash skip that particular file in the batch processing.
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Understanding Encoding Options
You can customize many settings when converting your original video to the Flash 
Video format. You can crop and resize your video to specific dimensions, just 
convert a snippet of the video, adjust the type of compression and the compression 
levels, and even apply filters to the video. To display the encoding options, click 
the Preset selection in the display list or choose Edit > Export Settings. The Export 
Settings dialog box appears.

Cropping Your Video
If you only want to show a portion of your video, you can crop it. Choose Edit > 
Reset Status to reset the Penguins.mov file so you can experiment with the crop-
ping settings.

1 Click the Crop button at the upper-left corner of the Export Settings dialog box. 
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The cropping box appears over the video preview window.

2 Drag the sides inward to crop from the top, bottom, left, or right. 

The grayed-out portions outside the box will be discarded. Flash displays the 
new dimensions next to your cursor. You can also use the Left, Top, Right, and 
Bottom settings above the preview window to enter exact pixel values.
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3 If you want to keep the crop in a standard proportion, click the Crop 
Proportions menu and choose a desired ratio. 

The cropping box will be constrained to the selected proportions.

4 To see the effects of the crop, click the Output tab. 

The preview window shows how your final video will appear.
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5 Exit the cropping mode by clicking the Crop button again under the Source tab. 
You will not need to crop the Penguins.mov video for this lesson.

Adjusting Video Length
Your video may have unwanted segments at the beginning or the end. You can 
shave off footage from either end to adjust the overall length of your video.

1 Click and drag the playhead (top marker) to scrub through your video to preview 
the footage. Place the playhead at the desired beginning point of your video.

Time markers indicate the number of seconds that have elapsed.

2 Click the Set In Point icon. 

The In point moves to the current position of the playhead.
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3 Drag the playhead to the desired ending point of your video.

4 Click the Set Out Point icon. 

The Out point moves to the current position of the playhead.

5 You can also simply drag the In and Out point markers to bracket the desired 
video segment. Drag the In and Out points back to their original positions 
because you do not need to adjust the video length for this lesson.

Note:##  When the 
playhead is selected, 
you can use the left or 
the right arrow keys on 
your keyboard to move 
back or ahead frame by 
frame for finer control.

Cue Points
At the bottom left of the Export Settings dialog box is an area where you can  
set cue points for your video.

Cue points are an advanced feature that lets you add special markers at various 
points along the video. With ActionScript, you can program Flash to recognize 
when those cue points are encountered, or you can navigate to specific cue points. 
Cue points can transform an ordinary, linear video into a true interactive, immersive 
video experience.
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Setting Advanced Video and Audio Options
The right side of the Export Settings dialog box contains 
all the advanced video and audio options. You can toggle 
between Simple mode and Advanced mode using the  
Mode icon . 

The Advanced mode shows all the settings for audio and 
video at the top of the panel. You can choose one of the  
preset options from the top Preset menu. At the bottom,  
you can navigate to different encoding options using the  
tabs. At the very bottom, Flash displays the estimated final 
output size.

You will export the Penguins.mov again but at a larger size.

1 Make sure that the Export Video and Export Audio boxes 
are selected. 

2 Click the Format tab and choose F4V. 

3 Click the Video tab. 
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4 Select Resize Video and click the Constrain option (the chain link icon). Enter 
480 for the Width and click outside the field to accept the change.

The Height automatically changes to keep the proportions of the video.

5 Click OK. 

Flash closes the Export Settings dialog box and saves your advanced video and 
audio settings.

6 Click Start Queue to begin the encoding process with your custom resize settings. 

Flash creates another F4V file of Penguins.mov. Delete the first one you created 
and rename the second one Penguins.f4v.

Saving Advanced Video and Audio Options
If you want to process many videos similarly, it makes sense to save your advanced 
video and audio options. You can do that in the Adobe Media Encoder. Once saved, 
you can easily apply your settings to other videos in the queue.

1 In the Export Settings dialog box, click the Save Preset button. 
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2 In the dialog box that opens, provide a descriptive name for the video and audio 
options. Click OK.

3 Return to the queue of videos. You can apply your custom settings to additional 
videos by simply choosing the preset from the Preset pull-down menu. 

Playback of External Video
Now that you have successfully converted your video to the correct Flash Video 
format, you can use it in your Flash zoo kiosk project. You will have Flash play each 
of the animal videos at the different labeled keyframes on the Timeline.

You will keep your videos external to the Flash project. By keeping videos external, 
you keep your Flash project small, and the videos can maintain different frame rates 
from your Flash project.

1 Open your 07_workingcopy.fla project in Flash CS4. 

2 Select the keyframe labeled penguins in the content layer.

Chapter 7. Working with Sound and Video. Adobe® Flash® CS4 Professional Classroom in a Book®, ISBN: 9780321606600
Prepared for matthew@choppingblock.com, Matthew Richmond
© 2009 Adobe System Incorporated and its Licensors.. This PDF is made available for personal use only during the relevant subscription term, subject to the Safari Terms of Service. Any
other use requires prior written consent from the copyright owner. Unauthorized use, reproduction and/or distribution are strictly prohibited and violate applicable laws. All rights reserved.



268 lesson 7 Working with sound and Video

3 Choose File > Import > Import Video.

The Import Video wizard appears.

4 In the Import Video wizard, select On Your Computer and click Browse 
(Windows) or Choose (Mac). 

5 In the dialog box, select Penguins.f4v from the Lesson07/07Start folder and  
click Open. 

6 Select the Load external video with playback component option. Click Next  
or Continue.

7 Select SkinUnderAllNoFullNoCaption.swf from the Skin menu and select color 
#333333 with a 75% Alpha. Click Next or Continue.

Note:##  The skin 
is a small SWF file 
that determines the 
functionality and 
appearance of the 
video’s controls. You 
can use one of the skins 
provided with Flash, or 
you can customize your 
own. To preview a skin, 
select it from the Skin 
menu.
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8 On the next screen of the Import Video wizard, review the information for the 
video file, and then click Finish to encode the file. 

9 A black box representing your video with the selected skin appears on the Stage. 
Place the video box on the left side of the Stage.

Chapter 7. Working with Sound and Video. Adobe® Flash® CS4 Professional Classroom in a Book®, ISBN: 9780321606600
Prepared for matthew@choppingblock.com, Matthew Richmond
© 2009 Adobe System Incorporated and its Licensors.. This PDF is made available for personal use only during the relevant subscription term, subject to the Safari Terms of Service. Any
other use requires prior written consent from the copyright owner. Unauthorized use, reproduction and/or distribution are strictly prohibited and violate applicable laws. All rights reserved.



270 lesson 7 Working with sound and Video

A playback component also appears in your Library. The component is a special 
widget that is used on the Stage to play your video.

10 Choose Control > Test Movie. Click the Magellanic Penguins button.

The video begins streaming into your Flash file. Use the controls to play, stop, 
and change the volume for the movie. Close the preview window. 
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11 The other animal videos have already been encoded (in FLV format) and 
provided in the 07Start folder. Import the Mandril.flv, Tiger.flv, and Lion.flv 
videos in each of their corresponding keyframes.

Controlling the Video Playback
The playback component lets you control which video plays, whether the video 
plays automatically, and other aspects of playback. The options for playback can 
be accessed by selecting Window > Component Inspector (Shift-F7). Parameters 
are listed in the left column, and their corresponding values are listed in the right 
column.

• To change the AutoPlay option, select true or false from the right column. True 
makes the video play automatically, and false pauses the video on the first frame.

Note:##  The FLV 
or F4V files, the 
07_workingcopy.swf 
file, and the skin file are 
all required for your zoo 
kiosk project to work.
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• To hide the controller and only display it when users roll their mouse cursor 
over the video, select true for the SkinAutoHide option.

• To choose a new controller (the skin), double-click the 
SkinUnderAllNoFullNoCaption.swf and select a new skin in the dialog box that 
appears.

• To change the transparency of the controller, enter a decimal value from 0 
(totally transparent) to 1 (totally opaque) for the SkinBackgroundAlpha.

• To change the color of the controller, click on the color chip and choose a new 
color for the SkinBackgroundColor.

• To change the video file or the location of the video file that Flash looks for to 
play, click the Source option.

In the Content Path dialog box, enter a new filename or click on the Folder icon 
to choose a new file to play.
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Working with Video and transparency
For the various animal videos, you want to show the entire frame with the animals 
in the foreground and the lush environment in the background. But sometimes you 
want to use a video file that doesn’t include a background. For this project, the zoo 
director was filmed in front of a green screen, which was removed using Adobe 
After Effects. When you use the video in Flash, the zoo director appears to be in 
front of the Flash background. A similar effect is used for news weatherpersons, 
where the background of the video is totally transparent and can show weather 
graphics behind the person.

Transparencies in video (called alpha channels) are supported only in the FLV format 
using the On2VP6 codec. When encoding a video with an alpha channel, be sure to 
select the Encode Alpha Channel option in the Video tab of the Export Settings.

You’ll import the video file, which is already in FLV format, into Flash for display 
with the playback component. However, you won’t include a skin, so users will be 
unable to control the video. The zoo director will appear directly on the Stage. 

Importing the Video Clip
Now you’ll use the Import Video wizard to import the Popup.flv file.

1 Insert a new layer called popup video.

2  Insert a keyframe at frame 35 and insert another keyframe at frame 40.

3  Select the keyframe at frame 35.
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4  Choose File > Import > Import Video. 

5  In the Import Video wizard, select On Your Computer and click Browse or 
Choose. Select the Popup.flv file in the Lesson07/07Start folder and click Open. 

6 Select Load external video with playback component. Click Next or Continue. 

7 Select None from the Skin menu and click Next or Continue. 
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8 Click Finish to import the video. 

A black box indicating the video appears on the Stage.

9 Use the Selection tool to position the new video just above the red bar and the 
sound buttons. 

The video appears in the popup video layer in the keyframe at frame 35 as the 
sound begins to fade out. At frame 40, where the penguin video is placed, the 
popup video is removed from the Timeline.
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Using a green screen
Professionals often film people in front of solid green or blue backgrounds, so that 
they can easily remove, or key, the background in a video-editing application such 
as Adobe After Effects. Then, the person is merged with a different background. The 
image of the zoo director was filmed in front of a green screen, which was removed 
in After Effects.

1 Shoot footage in front of a green 
screen.

• Use a green background that is 
flat, smooth, and free of shadows, 
so that the color is as pure as 
possible.

• Minimize the light that reflects off 
the green screen onto the subject.

• Keep movement to a minimum 
for Flash video; use a tripod if 
possible.

2  Remove the background in After 
Effects.

 Import the file as footage into After 
Effects, create a new composition, 
and drag it onto the Composition 
Timeline.

 Create a garbage mask to roughly 
outline the shape and remove most 
of the background. But be sure the 
subject never moves outside the mask!

 Use the Color Range keying effect to 
delete the rest of the background. 
You may need to do some fine-tuning 
with the Matte Choker and Spill 
Suppressor effects. A spill suppressor 
removes the light that splashes onto 
the edges of the subject.

3  Export to FLV format.

 Export the video file to Flash Video 
(FLV) format directly from After 
Effects. Be sure to select Encode 
Alpha Channel. The alpha channel 
is the selection around the subject. 
Encoding the alpha channel ensures 
that the video exports without a 
background.  
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10 Choose Control > Test Movie to see the video file that uses alpha channels. 
Close the preview window.

Embedding Flash Video
Embedded video is best for short clips that you want to integrate with other Flash 
elements. Embedded video requires the FLV format. The FLV file is saved in the 
Library of your Flash file, where you can place it on the Timeline and synchronize it 
with other animations or graphics.

Embedding video in Flash is supported by Flash Player versions 6 and later. Keep 
in mind the following limitations of embedded video: Flash cannot maintain audio 
synchronization in embedded video that runs over 120 seconds. The maximum 
length of embedded movies is 16,000 frames. Another drawback of embedding your 
video is the increase in the size of your Flash project, making testing the movie 
(Control > Test Movie) a longer process and the authoring sessions more tedious.

Because the embedded FLV plays within your Flash project, it is critically impor-
tant that your FLV have the same frame rate as your Flash file. If not, your embed-
ded video will not play at its intended speed. To make sure your FLV has the same 
frame rate as your FLA, be sure to set the correct frame rate in the Video tab of the 
Adobe Media Encoder.
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Encoding the FLV for Embedding
You’ll embed a short video of a polar bear in the beginning of your zoo kiosk project.

1 Open the Adobe Media Encoder. 

2 Click the Add button and choose the polarbear.mov file in the Lesson07/ 
07Start folder.

The polarbear.mov file is added to the queue.

3 Click Preset to open the Edit Export options. Click the Format tab and select FLV.

4 Click the Video tab and set the Frame Rate to 12. Make sure that the Resize 
Video checkbox is unchecked.
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The Flash file 07_workingcopy.fla is set at 12 frames per second, so you want 
your FLV to also be at 12 frames per second.

5 Deselect Export Audio at the top of the dialog box. Click OK.

6 Click Start Queue to encode your video.

The polarbear.flv file is created.

Embedding an FLV on the timeline
Once you have an FLV, you can import it into Flash and embed it on the Timeline.

1 Open the file 07_workingcopy.fla.

2 Select the first frame of the popup video layer.

3 Choose File > Import > Import Video. In the Import Video wizard, select On 
Your Computer and click Browse or Choose. Select the polarbear.flv file in the 
Lesson07/07Start folder and click Open.
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4 In the Video Import wizard, select Embed FLV in SWF and play in timeline. 
Click Next or Continue.

5 Deselect Expand timeline if needed and deselect Include audio. Click Next  
or Continue.

6 Click Finish to import the video. 

The video of the polar bear appears on the Stage.
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The FLV also appears in your Library.

7 Choose Control > Test Movie to see the embedded video file play from frame 1 
to frame 35.

Using Embedded Video
It’s useful to think of embedded video as a multiframe symbol, very much like a 
symbol with a nested animation. You can convert an embedded video to a movie 
clip symbol, and then motion tween it to create interesting effects.

Next, you’ll apply a motion tween to the embedded video so it fades out just before 
the zoo director pops up and speaks.

1 Select the embedded video on the Stage, right-click/Ctrl-click it, and select 
Create Motion Tween.

Note:##  You will 
not be able to hear 
audio in the authoring 
environment for 
embedded videos 
containing sound. To 
hear the audio, you 
must choose Control > 
Test Movie.
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2 Flash asks to convert the embedded video to a symbol so it can apply a motion 
tween. Click OK.

3 Flash asks to add enough frames inside the movie clip symbol so that the entire 
video can play. Click Yes.

A motion tween is created on the layer.

4 Select the motion tween and click the Motion Editor tab.

5 Collapse all the property categories. Click the Plus button next to Color Effect 
and choose Alpha.

The Alpha property is added to the motion tween.
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6 Select frame 25, right-click/Ctrl-click, and choose Add Keyframe. 

An Alpha keyframe appears at frame 25.

7 Select frame 30, right-click/Ctrl-click, and choose Add Keyframe. 

An Alpha keyframe appears at frame 30.

8 Select the last keyframe at frame 30 and drag it down to 0%. 

The Alpha is set to 0% at the last keyframe so the embedded video fades out 
from frame 25 to frame 30.

9 Choose Control > Test Movie to see the embedded video play and fade out.
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Review questions
1 How can you edit the length of a sound clip?

2 What is a skin for a video?

3 What are the limitations for embedded video clips?

4 What is a green screen, and how is it used?

Review Answers
1 To edit the length of a sound clip, select the keyframe that contains it and click Edit  

in the Property inspector. Then move the time slider in the Edit Envelope dialog box.

2 The skin is the combination of functionality and appearance of video controls,  
such as Play, Fast Forward, and Pause buttons. You can choose from a wide array  
of combinations with the buttons in different positions, and you can customize the 
skin. If you don’t want viewers to be able to control the video, apply No skin from  
the Skin menu.

3 When you embed a video clip, it becomes part of the Flash document and is included 
in the Timeline. Because embedded video clips significantly increase the size of the 
document and produce audio synchronization issues, it’s best to embed video only if  
it is less than 10 seconds in length and contains no audio track.

4 A green screen is a solid color background shot behind a video subject. The solid 
background is then removed from the footage in an application such as After Effects, 
so that the subject can be placed in front of a different background.
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